Опубликован: 03.10.2011 | Доступ: свободный | Студентов: 6575 / 1801 | Оценка: 4.48 / 4.40 | Длительность: 18:03:00

Лекция 12: Особенности протоколов вектора расстояния

< Лекция 11 || Лекция 12: 123 || Лекция 13 >
Аннотация: Рассмотрены особенности функционирования протокола маршрутизации RIP в некорректно спроектированной сети. Приведены общие сведения о протоколе EIGRP и его конфигурировании. Даны примеры отладки сети.

12.1. Протокол RIP

Протокол Routing Information Protocol (RIP) широко используется в сетях малого размера, когда на пути от источника до назначения максимальное число переходов между маршрутизаторами не превышает 15. Однако в случае некорректно спроектированной сети применение протокола RIP может привести к проблемам маршрутизации. Примером некорректно спроектированной сети является схема рис. 12.1 с таблицей адресов узлов (таблица 12.1).

Пример составной сети

Рис. 12.1. Пример составной сети

Из рис. 12.1 и таблицы 12.1 следует, что Сеть 1 (192.168.10.16/28) и Сеть 2 (192.168.10.32/27) являются подсетями сети 192.168.10.0/24. Сеть 4 (192.168.10.128/26) также является подсетью сети 192.168.10.0/24. Причем, Сети 1, 2 и Сеть 4 разделены Сетью 5 и Сетью 6.

Таблица 12.1. Адреса сетей, интерфейсов и узлов составной сети
Наименование Адрес Наименование Адрес

Сеть 1

f0/0

Host 1-1

Host 1-n

192.168.10.16/28

192.168.10.17

192.168.10.18

192.168.10.n

С

еть 2

f0/0

Host 2-1

Host 2-n

192.168.10.32/27

192.168.10.33

192.168.10.34

192.168.10.n

Сеть 3

f0/0

Host 3-1

Host 3-n

192.168.20.64/29

192.168.20.65

192.168.20.66

192.168.20.n

Сеть 4

f0/0

Host 4-1

Host 4-n

192.168.10.128/26

192.168.10.129

192.168.10.130

192.168.10.n

Сеть 5

s1/1

s1/2

200.5.5.0/30

200.5.5.1

200.5.5.2

Сеть 6

s1/1

s1/2

200.5.5.4/30

200.5.5.5

200.5.5.6

Конфигурирование маршрутизаторов (адресов интерфейсов и протокола RIP) проведено в соответствии с материалами лекций 10 и 11.

R_А(config)#router rip
R_А(config-router)#network 192.168.10.16
R_А(config-router)#network 192.168.10.32
R_А(config-router)#network 200.5.5.0

Ниже приведены результаты конфигурирования маршрутизатора А с использованием команд sh run и sh ip route:

R-А#sh run
...
interface FastEthernet0/0
 ip address 192.168.10.17 255.255.255.240
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 192.168.10.33 255.255.255.224
 duplex auto
 speed auto
!
interface Serial1/1
 ip address 200.5.5.1 255.255.255.252
 clock rate 64000
!
router rip
network 192.168.10.0
 network 200.5.5.0
 
R-А#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route
       
Gateway of last resort is not set

       192.168.10.0/24 is variably subnetted, 2 subnets, 2 masks
C         192.168.10.16/28 is directly connected, FastEthernet0/0
C         192.168.10.32/27 is directly connected, FastEthernet0/1
R      192.168.20.0/24 [120/1] via 200.5.5.2, 00:00:05, Serial1/1
       200.5.5.0/30 is subnetted, 2 subnets
C         200.5.5.0 is directly connected, Serial1/1
R         200.5.5.4 [120/1] via 200.5.5.2, 00:00:05, Serial1/1

Поскольку RIP относится к протоколам типа classfull, он объединяет отдельные подсети в рамках сети заданного класса, в данном случае сети класса С, что можно увидеть из распечатки команды show running-config. Две подсети (192.168.10.16 и 192.168.10.32), которые были заданы при конфигурировании, протокол RIP объединил в сеть класса С (network 192.168.10.0).

Из распечатки команды sh ip route следует, что сеть 192.168.10.0 с маской 255.255.255.0 разделена на две непосредственно присоединенных подсети с масками разной длины: 192.168.10.16/28 и 192.168.10.32/27. При этом сеть класса С 192.168.10.0/24 называется родительской, а сети 192.168.10.16/28 и 192.168.10.32/27 – дочерними.

Кроме того, в таблице маршрутизации R_А отсутствует маршрут к сети 192.168.10.128/26, поскольку протокол RIP в своих обновлениях не передает маску подсети, поэтому подсети объединены в рамках сети 192.168.10.0/24. Из-за отсутствия в таблице маршрутизации R_А маршрута к сети 192.168.10.128/26 "пингование" интерфейса 192.168.10.129 – неудачное:

R-А>ping 192.168.10.129

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.10.129, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

Конфигурирование маршрутизатора В дало следующие результаты:

R-В#sh run
...
interface FastEthernet0/0
  ip address 192.168.20.65 255.255.255.248
  duplex auto
  speed auto
!
interface Serial1/1
  ip address 200.5.5.5 255.255.255.252
  clock rate 64000
!
interface Serial1/2
  ip address 200.5.5.2 255.255.255.252
!
router rip
  network 192.168.20.0
  network 200.5.5.0
  
R-В#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
...

Gateway of last resort is not set

R   192.168.10.0/24 [120/1] via 200.5.5.1, 00:00:15, Serial1/2
                     [120/1] via 200.5.5.6, 00:00:02, Serial1/1
    192.168.20.0/29 is subnetted, 1 subnets
C      192.168.20.64 is directly connected, FastEthernet0/0
    200.5.5.0/30 is subnetted, 2 subnets
C      200.5.5.0 is directly connected, Serial1/2
C      200.5.5.4 is directly connected, Serial1/1

Из распечатки команды show running-config следует, что протокол RIP объединил две подсети 200.5.5.0/30 и 200.5.5.4/30 в сеть network 200.5.5.0. Кроме того, и это очень важно, в таблице маршрутизации R_В имеется два маршрута к сети 192.168.10.0/24, причем один путь направлен влево через интерфейс 200.5.5.1, а другой – вправо через 200.5.5.6. Поскольку оба пути характеризуются одинаковой метрикой, равной 1, протокол RIP использует баланс маршрутов и поочередно посылает пакеты через два разных интерфейса (next hop). Поэтому один пакет доходит до адресата, а второй – нет, что видно из следующей команды:

R_В#ping 192.168.10.17

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.10.17, timeout is 2 seconds:
!U!.!
Success rate is 60 percent (3/5), round-trip min/avg/max = 34/59/59 ms

Пакеты эхо-запроса поочередно попадают то к адресату назначения (ответ !), то направляются в другую сторону, где устройство назначения недоступно (U) или время ожидания превышает допустимое (.).

В таблице маршрутизации R_С отсутствует маршрут к подсетям 192.168.10.16/28 и 192.168.10.32/27, поскольку они объединены с подсетью 192.168.10.128 в рамках родительской сети 192.168.10.0:

R_С#sh ip route
...

   192.168.10.0/26 is subnetted, 1 subnets
C     192.168.10.128 is directly connected, FastEthernet0/0
R  192.168.20.0/24 [120/1] via 200.5.5.5, 00:00:03, Serial1/2
   200.5.5.0/30 is subnetted, 2 subnets
R     200.5.5.0 [120/1] via 200.5.5.5, 00:00:03, Serial1/2
C     200.5.5.4 is directly connected, Serial1/2

Таким образом, в неправильно спроектированной сети ( рис. 12.1) подсети 192.168.10.16/28, 192.168.10.32/27 и 192.168.10.128/26 разделены (или, по-другому, разобщены) сетями 200.5.5.0/30 и 200.5.5.4/30. При использовании протокола RIP в такой сети ее работоспособность нарушена. Это происходит из-за того, что протокол RIP в своих обновлениях ( update ) не передает маршрутной информацией значения маски подсетей.

< Лекция 11 || Лекция 12: 123 || Лекция 13 >
Александр Хованский
Александр Хованский
в курсе построение сетей на базе коммутаторов и маршрутизаторов некорректно задан вопрос. звучит так сколько портов сконфинурировать в VLAN0 для управления коммутатором. (поменяйте например на VLAN1 или VLAN управления ) 0-го VLAN не может быть
Алексей Фомичевский
Алексей Фомичевский
Украина, Запорожье, ЗГИА