Опубликован: 03.10.2011 | Доступ: свободный | Студентов: 6575 / 1801 | Оценка: 4.48 / 4.40 | Длительность: 18:03:00
Лекция 11:

Конфигурирование маршрутизации

< Лекция 10 || Лекция 11: 123 || Лекция 12 >
Аннотация: Рассмотрены основы конфигурирования статической и динамической маршрутизации, а также маршрутизации по умолчанию. Приведены примеры конфигурирования маршрутизаторов. Проанализированы таблицы маршрутизации, методы отладки сети.

11.1. Конфигурирование статической маршрутизации

Маршруты к адресатам назначения могут быть сконфигурированы для каждого маршрутизатора вручную администратором ( статическая маршрутизация ) или созданы с помощью маршрутизирующих протоколов ( динамическая маршрутизация ). При рассмотрении конфигурирования статической маршрутизации используется составная сеть, структурная схема которой приведена на рис. 11.1.

Пример составной сети

Рис. 11.1. Пример составной сети

Именно для этой сети ниже приведены примеры конфигурирования маршрутизаторов. Адреса интерфейсов маршрутизаторов и узлов составной сети даны в таблице 11.1. Чтобы сконфигурировать статическую маршрутизацию, администратор должен задать маршруты ко всем возможным сетям назначения, которые не присоединены к данному маршрутизатору.

Таблица 11.1. Адреса узлов составной сети
Наименование Адрес Наименование Адрес

Сеть 1

f0/0

Host 1-1

Host 1-n

192.168.10.0/24

192.168.10.1

192.168.10.2

192.168.10.n

Сеть 2

f0/0

Host 2-1

Host 2-n

192.168.20.0/24

192.168.20.1

192.168.20.2

192.168.20.n

Сеть 3

f0/0

Host 3-1

Host 3-n

192.168.30.0/24

192.168.30.1

192.168.30.2

192.168.30.n

Сеть 4

f0/0

Host 4-1

Host 4-n

192.168.40.0/24

192.168.40.1

192.168.40.2

192.168.40.n

Сеть 5

s1/1

s1/2

200.50.50.0/24

200.50.50.11

200.50.50.12

Сеть 6

s1/1

s1/2

200.60.60.0/24

200.60.60.11

200.60.60.12

Сеть 7

s1/1

s1/2

200.70.70.0/24

200.70.70.11

200.70.70.12

Для конфигурирования статической маршрутизации используется команда ip route, которая содержит три параметра:

  • адрес сети назначения,
  • сетевую маску и
  • адрес входного интерфейса следующего маршрутизатора на пути к адресату ( next hop ).

Адрес входного интерфейса следующего маршрутизатора на пути к адресату также называют шлюзом по умолчанию. Например для пакетов, попавших в маршрутизатор Router_В, шлюзами по умолчанию будут:

  1. интерфейс s1/1 маршрутизатора Router_A с адресом 200.50.50.11,
  2. интерфейс s1/2 маршрутизатора Router_С с адресом 200.60.60.12.

Ниже приведен пример конфигурирования статической маршрутизации для маршрутизатора Router_В. Данный маршрутизатор непосредственно связан с сетями 192.168.20.0, 200.50.50.0 и 200.60.60.0, поэтому статическая маршрутизация должна создаваться для остальных четырех сетей, которые непосредственно не присоединены к Router_В.

Router>enable
Router#config t
Router(config)#hostname Router_B
Router_B(config)#ip route 192.168.10.0 255.255.255.0 200.50.50.11
Router_B(config)#ip route 192.168.30.0 255.255.255.0 200.60.60.12
Router_B(config)#ip route 192.168.40.0 255.255.255.0 200.60.60.12
Router_B(config)#ip route 200.70.70.0 255.255.255.0 200.60.60.12
Router_B(config)#exit
Router_B#copy run start

Верификация статической конфигурации производится командами show ip route и show running-config. Например, по команде show ip route отображается таблица маршрутизации:

Router_B#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
  D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
  N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
  E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
  i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2,
  * - candidate default, U - per-user static route, o – ODR
  P – periodic downloaded static route

Gateway of last resort is not set

S 192.168.10.0/24 [1/0] via 200.50.50.11
C 192.168.20.0/24 is directly connected. FastEthernet0/0
S 192.168.30.0/24 [1/0] via 200.60.60.12
S 192.168.40.0/24 [1/0] via 200.60.60.12
C 200.50.50.0/24 is directly connected. Serial1/2
C 200.60.60.0/24 is directly connected. Serial1/1
S 200.70.70.0/24 [1/0] via 200.60.60.12
Router_B#

Символами С в таблице маршрутизации помечены непосредственно присоединенные к маршрутизатору сети, а символом S – созданные администратором статические маршруты к указанным сетям. Так, статический маршрут к сети 192.168.10.0 проложен через интерфейс s1/1 маршрутизатора Router_A с адресом 200.50.50.11, маршруты к трем другим сетям проложены через шлюз 200.60.60.12. Приведенные в распечатке значения [1/0] представляют собой "административное расстояние" и метрику. Маршрутизатор задействует административное расстояние каждого маршрута, чтобы определить лучший путь к адресату. Административное расстояние – это число, величина которого определяется источником задаваемого маршрута. Меньшее административное расстояние означает более надежный источник. Например, при статической маршрутизации используется значение административного расстояния, равное 1, а для протокола маршрутизации RIP административное расстояние – 120. Различные протоколы маршрутизации имеют различные заданные по умолчанию административные расстояния (таблица 11.2). В таблице маршрутизации устанавливается путь с самым низким административным расстоянием. Метрика статического маршрута равна 1.

Таблица 11.2. Административные расстояния по умолчанию
Протокол Административное расстояние Протокол Административное расстояние
Connected 0 OSPF 110
Static 1 IS-IS 115
EIGRP summary 5 RIP 120
eBGP 20 EIGRP (External) 170
EIGRP (Internal) 90 iBGP (External) 200
IGRP 100

Таким образом, по команде sh ip route в таблице маршрутизации отображаются адреса сетей назначения и адреса входных интерфейсов ближайших маршрутизаторов на пути к адресату. Созданные статические маршруты можно также посмотреть с помощью команды show runningconfig (сокращенно sh run ), часть распечатки которой приведена ниже:

Router_B#sh run
Current configuration:
version 12.3
      ...
hostname Router_B
!
interface FastEthernet0/0
ip address 192.168.20.1 255.255.255.0
duplex auto
speed auto
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial1/0
no ip address
shutdown
!
interface Serial1/1
ip address 200.60.60.11 255.255.255.0
clock rate 64000
!
interface Serial1/2
ip address 200.50.50.12 255.255.255.0
       ...
ip classless
ip route 192.168.10.0 255.255.255.0 200.50.50.11
ip route 192.168.30.0 255.255.255.0 200.60.60.12
ip route 192.168.40.0 255.255.255.0 200.60.60.12
ip route 200.70.70.0 255.255.255.0 200.60.60.12
      ...
end

Удаление статических маршрутов производится командой no ip route, например:

Router_B(config)#no ip route 200.70.70.0 255.255.255.0 200.60.60.12

При необходимости можно полностью очистить конфигурацию любого маршрутизатора, что производится с помощью команды

Router#erase start

При этом удаляется файл startup-configuration, хранящийся в NVRAM. Если после этого выключить маршрутизатор и затем вновь его включить, то конфигурация маршрутизатора будет очищена.

В ряде случаев при маршрутизации задают наименование выходного интерфейса маршрутизатора вместо адреса шлюза по умолчанию (next hop). Ниже приведен пример конфигурирования маршрутизатора Router_B ( рис. 11.1) с использованием выходного интерфейса:

Router_B(config)#ip route 192.168.10.0 255.255.255.0 S1/2
Router_B(config)#ip route 192.168.30.0 255.255.255.0 S1/1
Router_B(config)#ip route 192.168.40.0 255.255.255.0 S1/1
Router_B(config)#ip route 200.70.70.0 255.255.255.0 S1/1

Подобное конфигурирование ускоряет процесс обработки пакета в маршрутизаторе.

Верификация работоспособности сети и таблицы маршрутизации производится с использованием команд ping и traceroute, которые проверяют обеспечение IP-связи между маршрутизаторами. Команды ping и traceroute являются утилитами протокола ICMP, который разработан в дополнение к протоколу IP, не имеющему средств проверки достижимости или недостижимости узлов и сетей. Эти команды позволяют с каждого маршрутизатора производить тестирование (прозвонку) интерфейсов других маршрутизаторов и узлов, например:

Router_B#ping 192.168.10.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.10.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms

Значки "!!!!!" означают, что связь между маршрутизатором Router_B и интерфейсом 192.168.10.1 маршрутизатора Router_А удовлетворительная, 100% запросов и ответов (5 из пяти) переданы без искажений. При отсутствии возможности прозвонить узел или интерфейс вместо символов "!!!!!" будет сформирована последовательность из пяти точек – "...".

При использовании команды traceroute ответ передается с каждого промежуточного соединения, например:

Router_A#traceroute 192.168.40.1
Type escape sequence to abort.
Tracing the route to 192.168.40.1
   1 200.50.50.12 58 msec 48 msec 55 msec
   2 200.60.60.12 106 msec 97 msec 49 msec
   3 200.70.70.12 171 msec 120 msec 127 msec

Конфигурирование статической маршрутизации по умолчанию

Статическая маршрутизация по умолчанию означает, что если пакет предназначен для сети, которая не перечислена в таблице маршрутизации, то маршрутизатор отправит пакет по заданному по умолчанию маршруту. При этом маршрутизатор направляет пакеты к следующему маршрутизатору, когда тот в таблице не задан явно. Заданные по умолчанию маршруты устанавливаются как часть статической конфигурации.

В процессе конфигурирования маршрутизации по умолчанию, так же как при статической маршрутизации, используют команду ip route, но в адресе и маске сети (и подсети) задействуют все нули, которые означают все сети и все маски. Подобная маршрутизация устанавливается для тупиковых маршрутизаторов, т. е. она может быть установлена для маршрутизаторов A и D ( рис. 11.1), потому что через них лежит единственный путь в составную сеть и из нее. Например, для всех пакетов, попавших в маршрутизатор A, маршрут по умолчанию будет через его порт s1/1, т. е. шлюзом будет входной интерфейс маршрутизатора Router_В с адресом 200.50.50.12.

При конфигурировании маршрутизаторов A и D необходимо предварительно удалить все статические маршруты и затем установить маршрут по умолчанию, например (опция "ip routing" должна быть включена):

Router_A#config t
Router_A(config)#ip route 0.0.0.0 0.0.0.0 200.50.50.12

После конфигурирования маршрутизации по умолчанию необходимо протестировать сеть ( рис. 11.1), используя команды ping, traceroute, tracert.

Иногда маршрутизатор получает пакеты для неизвестной подсети, входящей в известную сеть, которая объединяет подсети. При этом маршрутизатор может уничтожить такие пакеты. Для предотвращения этого нужно использовать команду глобальной конфигурации ip classless, чтобы программное обеспечение Cisco IOS не уничтожало пакеты, а отправляло эти пакеты по маршруту умолчания:

Router_A#config t
Router_A(config)#ip route 0.0.0.0 0.0.0.0 192.168.50.2
Router_A(config)#ip classless
Router_A(config)#

В режиме ip classless пакеты могут быть отправлены по маршруту умолчания или по суммарному (агрегированному) маршруту, который охватывает больший диапазон подсетей с единственным входом. Например, если какое-то предприятие использует полную подсеть 10.10.0.0/16, то суммарным маршрутом для подсети 10.10.10.0/24 будет 10.10.0.0/16. Команда ip classless применяется по умолчанию в Cisco IOS Software Release 11.3 и позже. Чтобы отключить эту команду, задействуется ее отрицательная форма – no ip classless.

< Лекция 10 || Лекция 11: 123 || Лекция 12 >
Александр Хованский
Александр Хованский
в курсе построение сетей на базе коммутаторов и маршрутизаторов некорректно задан вопрос. звучит так сколько портов сконфинурировать в VLAN0 для управления коммутатором. (поменяйте например на VLAN1 или VLAN управления ) 0-го VLAN не может быть
Алексей Фомичевский
Алексей Фомичевский
Украина, Запорожье, ЗГИА