Опубликован: 11.02.2017 | Доступ: свободный | Студентов: 2413 / 553 | Длительность: 13:28:00
Лекция 2:

Статическая маршрутизация

< Лекция 1 || Лекция 2: 12345 || Лекция 3 >
Аннотация: Рассмотрены основы функционирования и конфигурирования статической маршрутизации сетей IPv4, IPv6, а также маршрутизации по умолчанию. Приведены примеры конфигурирования маршрутизаторов. Проанализированы таблицы маршрутизации, методы отладки сети.

2.1. Основы статической маршрутизации

Маршруты к удаленным сетям могут быть сконфигурированы для каждого маршрутизатора вручную администратором (статическая маршрутизация) или созданы с помощью маршрутизирующих протоколов (динамическая маршрутизация).

Статические маршруты полностью определены администратором, поэтому они более безопасны, требуют меньше вычислительных ресурсов и более узкую полосу пропускания по сравнению с динамическими маршрутами. Однако сети, использующие статическую маршрутизацию, плохо масштабируемы, при изменении топологии требуется внесение изменений администратором в конфигурацию, что может приводить к ошибкам. Поэтому статическая маршрутизация используется либо в малых сетях, либо в комбинации с протоколами динамической маршрутизации на отдельных участках сети. Статические маршруты, по сравнению с динамическими, характеризуются более высоким приоритетом, поскольку административное расстояние AD = 1 (см. табл. 1.1).

Статическая маршрутизация часто используется в тупиковых сетях, обмен данными с которыми реализуется через маршрутизатор, который подключен к одному соседнему маршрутизатору. При рассмотрении статической маршрутизации используется составная сеть, структурная схема которой приведена на рис. 2.1. В приведенной схеме сети тупиковой является Сеть 1, а тупиковым маршрутизатором - R-А, поскольку он соединен только с маршрутизатором R-В. Все пакета из Сети 1 могут быть отправлены только через маршрутизатор R-А по стандартному статическому маршруту в маршрутизатор R-В.

Статическая маршрутизация используется также при создании маршрута по умолчанию, который указывает путь к сетям, не имеющим соответствующих входов в таблице маршрутизации. В схеме сети рис. 2.1 пакеты с неизвестными адресами сетей назначения из маршрутизатора R-С можно направлять в Интернет, т.е. в сеть провайдера ISP. Адрес маршрута по умолчанию 0.0.0.0/0 означает любые адреса сетей с любыми масками.

Пример составной сети

Рис. 2.1. Пример составной сети

Статическая маршрутизация также используется при формировании суммарных(объединенных) маршрутов, что сокращает количество записей в таблице маршрутизации (см. курс "Основы построения сетей пакетной коммутации").

Кроме того, для создания резервных путей конфигурируются плавающие статические маршруты. Когда основной маршрут "падает", включается резервный, для чего администратор вручную задает резервному пути более высокое значение административного расстояния AD. Так если основной маршрут имеет административное расстояние 1, то резервному статическому пути следует задать AD> 1,например, AD = 5.

2.2. Конфигурирование статической маршрутизации

Чтобы сконфигурировать статическую маршрутизацию администратор должен задать маршруты ко всем возможным сетям назначения, которые не присоединены непосредственно к данному маршрутизатору. Например, из маршрутизатора R-A ( рис. 2.1), к которому прямо присоединены две сети (Сеть 1, Сеть 4), необходимо проложить маршруты к четырем оставшимся сетям (из шести представленных на схеме). К маршрутизатору R-Bпрямо присоединены 3 сети (Сеть 2, Сеть 4, Сеть 5), поэтому из него следует проложить 3 маршрута к оставшимся сетям.

Для конфигурирования статической маршрутизации используется команда ip route, которая содержит три параметра:

  • адрес сети назначения,
  • сетевую маску,
  • адрес входного интерфейса следующего маршрутизатора на пути к адресату (next hop) или идентификатор выходного интерфейса.

Адрес входного интерфейса следующего маршрутизатора (следующего перехода) на пути к адресату иногда называют шлюзом. Например, для пакетов, попавших в маршрутизатор R-В, шлюзами будут:

  1. Интерфейс s1/1 маршрутизатора R-A с адресом 200.4.4.11,
  2. Интерфейс s1/2 маршрутизатора R-С с адресом 200.5.5.12.

Ниже приведен пример конфигурирования статической маршрутизации для Cisco-маршрутизатора R-В, когда используется адрес следующего перехода. Маршрутизатор R-В непосредственно связан с сетями 192.168.20.0, 200.4.4.0 и 200.5.5.0, поэтому статические маршруты нужно создать для остальных трех сетей, которые прямо не присоединены к R-В.

Router#config t
Router(config)#hostname R-B
R-B(config)#ip route 192.168.10.0 255.255.255.0 200.4.4.11
R-B(config)#ip route 192.168.30.0 255.255.255.0 200.5.5.12
R-B(config)#ip route 200.6.6.0 255.255.255.0 200.5.5.12
R-B(config)#exit
R-B#copy run start
  

Аналогично конфигурируются остальные маршрутизаторы.

Верификация статической конфигурации производится по командам show ip route и show running-config. Например, по команде show ip route отображается таблица маршрутизации:

R-B#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
	D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
	N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
	E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
	i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2,
	* - candidate default, U - per-user static route, o - ODR
	P - periodic downloaded static route

Gateway of last resort is not set

S	192.168.10.0/24 [1/0] via 200.4.4.11
C	192.168.20.0/24 is directly connected. FastEthernet0/0
S	192.168.30.0/24 [1/0] via 200.5.5.12 
C	200.4.4.0/24 is directly connected. Serial1/2
C	200.5.5.0/24 is directly connected. Serial1/1
S	200.6.6.0/24 [1/0] via 200.5.5.12  
R-B#
  

Символами С в таблице маршрутизации помечены непосредственно присоединенные к маршрутизатору R-В сети, а символом S - созданные администратором статические маршруты к удаленным сетям. Так статический маршрут к сети 192.168.10.0 проложен через интерфейс s1/1 маршрутизатора R-A с адресом 200.4.4.11, маршруты к двум другим сетям проложены через шлюз 200.5.5.12.Приведенные в распечатке значения [1/0] представляют собой административное расстояние AD = 1 и метрику = 0.

При получении маршрутизатором R-В пакета, адресованного, например, узлу в сети 192.168.30.0, производится обращение к таблице маршрутизации, где есть строка S 192.168.30.0/24 [1/0] via 200.5.5.12, в которой указано, что адресом следующего перехода будет 200.5.5.12. Однако в этой строке таблицы не указан выходной интерфейс, на который следует скоммутировать поступивший пакет. Поэтому определяется сеть адреса следующего перехода (200.5.5.0) и производится второе обращение к таблице маршрутизации, что называется рекурсией. Из таблицы следует, что сеть 200.5.5.0 присоединена к интерфейсу Serial1/1. Таким образом, при создании маршрутов следующего перехода производится рекурсивная обработка маршрута, т.е. два обращения к таблице, что замедляет процесс обработки маршрута.

Для ускорения процесса маршрутизации вместо адреса следующего перехода (next hop) можно задать идентификатор выходного интерфейса маршрутизатора и тем самым избежать рекурсивной обработки маршрута. При этом формируется прямо присоединенный статический маршрут. В процессе конфигурирования предварительно нужно удалить все ранее созданные статические маршруты по команде no ip route:

R-B(config)#no ip route 200.6.6.0 255.255.255.0 200.5.5.12
  

Ниже приведен пример конфигурирования маршрутизатора R-B ( рис. 2.1) с использованием выходного интерфейса:

R-B(config)#ip route 192.168.10.0 255.255.255.0 S1/2
R-B(config)#ip route 192.168.30.0 255.255.255.0 S1/1
R-B(config)#ip route 200.6.6.0 255.255.255.0 S1/1
  

В этом случае таблица маршрутизации выглядит следующим образом:

R-B#show ip route
...
Gateway of last resort is not set

S  192.168.10.0/24 is directly connected, Serial1/2
C  192.168.20.0/24 is directly connected, FastEthernet0/0
S  192.168.30.0/24 is directly connected, Serial1/1
C  200.4.4.0/24 is directly connected, Serial1/2
C  200.5.5.0/24 is directly connected, Serial1/1
S  200.6.6.0/24 is directly connected, Serial1/1
R-B#
  

Когда необходимо посмотреть только статические маршруты можно использовать команду show ip route static.

В созданных маршрутах сразу указан выходной интерфейс, поэтому нет необходимости в рекурсивной обработке. Записи маршрутов к удаленным сетям изменились и по форме стали такими же, как записи прямо присоединенных сетей.

Созданные статические маршруты можно посмотреть не только по команде show ip route, когда в таблице маршрутизации отображаются адреса сетей назначения, но также с помощью команды show running-config (сокращенно sh run), часть распечатки которой приведена ниже:

R-B#show run
Building configuration...
...
interface FastEthernet0/0
 ip address 192.168.20.1 255.255.255.0
 duplex auto
 speed auto
!
interface Serial1/1
 ip address 200.5.5.11 255.255.255.0
 clock rate 64000
!
interface Serial1/2
 ip address 200.4.4.12 255.255.255.0
!
ip classless
ip route 192.168.30.0 255.255.255.0 Serial1/1 
ip route 192.168.10.0 255.255.255.0 Serial1/2 
ip route 200.6.6.0 255.255.255.0 Serial1/1 
!
R-B#
  

Однако использование прямо присоединенных (подключенных) статических маршрутов не всегда возможно. Например, если в сети рис. 2.2 задать прямо присоединенный маршрут из R-A в сеть 192.168.30.0

R-А(config)#ip route 192.168.30.0 255.255.255.0 g0/1
  

то он не будет определен, поскольку из коммутатора Sw2, соединяющего интерфейс G0/1 маршрутизатора R-A и G0/0 маршрутизатора R-B, возможны и другие пути.

Пример соединения GigabitEthernet

Рис. 2.2. Пример соединения GigabitEthernet

Поэтому в случае Ethernet-соединений необходимо задавать не только выходной интерфейс, но и адрес следующего перехода:

R-А(config)#ip route 192.168.30.0 255.255.255.0 g0/1 192.168.20.2
  

В этом случае реализуется полностью заданный статический маршрут.

Верификация работоспособности сети и таблицы маршрутизации производится с использованием команд ping и traceroute, которые проверяют обеспечение IP-связи между маршрутизаторами. Команды ping и traceroute являются утилитами протокола ICMP, который разработан в дополнение к протоколу IP, не имеющему средств проверки достижимости или недостижимости узлов и сетей. Эти команды позволяют с каждого маршрутизатора и конечного узла производить тестирование (прозвонку) интерфейсов других маршрутизаторов и узлов.

Маршруты удаляются из таблицы маршрутизации, если выходной интерфейс маршрутизатора прекращает функционирование. Поэтому при отладке сети необходимо проверять не только таблицу маршрутизации, но и состояние интерфейсов. Совокупность команд ping, show ip route, show running-config и show ip interface brief позволяет в большинстве случаев отладить сеть и устранить неполадки.

< Лекция 1 || Лекция 2: 12345 || Лекция 3 >
Богдан Божок
Богдан Божок

Поделитесь пожалуйста ► Первой частью курса.

В первой лекции упоминается, цитирую: "В первой части настоящего курса отмечалось, что соединение локальных сетей LAN..." 

Дмитрий Михайлусов
Дмитрий Михайлусов
Елена Игнатко
Елена Игнатко
Россия, Москва
Елизавета Ашмарова
Елизавета Ашмарова
Россия